McCain X1 Source Available

Discussion of anything and everything relating to chess playing software and machines.

Moderators: hgm, Harvey Williamson, bob

Forum rules
This textbox is used to restore diagrams posted with the [d] tag before the upgrade.
User avatar
Eduard
Posts: 103
Joined: Fri Oct 26, 2018 10:58 pm
Location: Germany
Full name: Eduard Nemeth
Contact:

Re: McCain X1 Source Available

Post by Eduard » Mon Feb 11, 2019 3:34 pm

Thanks!

Question: What does the option bench_KNPS stand for?

Steppenwolf
Posts: 11
Joined: Thu Jan 31, 2019 3:54 pm
Full name: Sven Steppenwolf

Re: McCain X1 Source Available

Post by Steppenwolf » Mon Feb 11, 2019 3:38 pm

@Eduard,

geht bei Dir das compilieren von Lc0 auf dem Mac?

maxdeg
Posts: 150
Joined: Thu Mar 10, 2016 5:17 pm
Location: Canada

Re: McCain X1 Source Available

Post by maxdeg » Mon Feb 11, 2019 4:18 pm

MikeB wrote:
Mon Feb 11, 2019 3:02 pm
maxdeg wrote:
Mon Feb 11, 2019 10:23 am
Thanks Mike .. :D
Followed instructions to the letter.
All installed successfully.

#1 .. your compile has issues or should I say my Mac has
#2 .. ./build.sh had issues too

(build/release >> is it a folder ??)

Last login: Mon Feb 11 04:47:11 on ttys000
You have new mail.
➜ ~ ./build.sh
zsh: no such file or directory: ./build.sh

➜ ~ /Users/maxdeg/Desktop/lc0
dyld: Library not loaded: @rpath/libprotobuf-lite.dylib
Referenced from: /Users/maxdeg/Desktop/lc0
Reason: image not found
[1] 11469 abort /Users/maxdeg/Desktop/lc0

➜ ~

Any ideas please ?
(build/release >> is it a folder ??) -> yes, but you will not see it until after a successful build

zsh: no such file or directory: ./build.sh -> not sure why , but I never use zsh , you might want to try bash - type "bash -l" at the command prompt , type "zsh" again to go back again. I'm just guessing , I'm not a shell expert by any means. You might have to change build.sh permissions to run, "chmod 755 build.sh" ?

dyld: Library not loaded: @rpath/libprotobuf-lite.dylib - see my posts above ..( which I think you have seen already)
I've made a copy of your instructions - many thanks.
One problem - I cant seem to find the 'subprojects' folder anywhere - Finder/Spotlight - no help.
For sure its hiding in plain sight - point me to it please !
Okay will return to bash.

MikeB
Posts: 2822
Joined: Thu Mar 09, 2006 5:34 am
Location: Pen Argyl, Pennsylvania

B

Post by MikeB » Mon Feb 11, 2019 7:53 pm

maxdeg wrote:
Mon Feb 11, 2019 4:18 pm
MikeB wrote:
Mon Feb 11, 2019 3:02 pm
maxdeg wrote:
Mon Feb 11, 2019 10:23 am
Thanks Mike .. :D
Followed instructions to the letter.
All installed successfully.

#1 .. your compile has issues or should I say my Mac has
#2 .. ./build.sh had issues too

(build/release >> is it a folder ??)

Last login: Mon Feb 11 04:47:11 on ttys000
You have new mail.
➜ ~ ./build.sh
zsh: no such file or directory: ./build.sh

➜ ~ /Users/maxdeg/Desktop/lc0
dyld: Library not loaded: @rpath/libprotobuf-lite.dylib
Referenced from: /Users/maxdeg/Desktop/lc0
Reason: image not found
[1] 11469 abort /Users/maxdeg/Desktop/lc0

➜ ~

Any ideas please ?
(build/release >> is it a folder ??) -> yes, but you will not see it until after a successful build

zsh: no such file or directory: ./build.sh -> not sure why , but I never use zsh , you might want to try bash - type "bash -l" at the command prompt , type "zsh" again to go back again. I'm just guessing , I'm not a shell expert by any means. You might have to change build.sh permissions to run, "chmod 755 build.sh" ?

dyld: Library not loaded: @rpath/libprotobuf-lite.dylib - see my posts above ..( which I think you have seen already)
I've made a copy of your instructions - many thanks.
One problem - I cant seem to find the 'subprojects' folder anywhere - Finder/Spotlight - no help.
For sure its hiding in plain sight - point me to it please !
Okay will return to bash.
/lc0/build/release/subprojects
Attachments
Screenshot 2019-02-11 14.53.24.png
Screenshot 2019-02-11 14.53.24.png (61.3 KiB) Viewed 127 times

maxdeg
Posts: 150
Joined: Thu Mar 10, 2016 5:17 pm
Location: Canada

Re: B

Post by maxdeg » Mon Feb 11, 2019 10:03 pm

MikeB wrote:
Mon Feb 11, 2019 7:53 pm
maxdeg wrote:
Mon Feb 11, 2019 4:18 pm
MikeB wrote:
Mon Feb 11, 2019 3:02 pm
maxdeg wrote:
Mon Feb 11, 2019 10:23 am
Thanks Mike .. :D
Followed instructions to the letter.
All installed successfully.

#1 .. your compile has issues or should I say my Mac has
#2 .. ./build.sh had issues too

(build/release >> is it a folder ??)

Last login: Mon Feb 11 04:47:11 on ttys000
You have new mail.
➜ ~ ./build.sh
zsh: no such file or directory: ./build.sh

➜ ~ /Users/maxdeg/Desktop/lc0
dyld: Library not loaded: @rpath/libprotobuf-lite.dylib
Referenced from: /Users/maxdeg/Desktop/lc0
Reason: image not found
[1] 11469 abort /Users/maxdeg/Desktop/lc0

➜ ~

Any ideas please ?
(build/release >> is it a folder ??) -> yes, but you will not see it until after a successful build

zsh: no such file or directory: ./build.sh -> not sure why , but I never use zsh , you might want to try bash - type "bash -l" at the command prompt , type "zsh" again to go back again. I'm just guessing , I'm not a shell expert by any means. You might have to change build.sh permissions to run, "chmod 755 build.sh" ?

dyld: Library not loaded: @rpath/libprotobuf-lite.dylib - see my posts above ..( which I think you have seen already)
I've made a copy of your instructions - many thanks.
One problem - I cant seem to find the 'subprojects' folder anywhere - Finder/Spotlight - no help.
For sure its hiding in plain sight - point me to it please !
Okay will return to bash.
/lc0/build/release/subprojects
Thank You .. :D
For some reason that folder does not exist - search via Finder I get dumped somewhere else.
Anyway I wanted a Mac version but its not a big deal as I now have a Windoze system.

Your assistance appreciated.

MikeB
Posts: 2822
Joined: Thu Mar 09, 2006 5:34 am
Location: Pen Argyl, Pennsylvania

Re: B

Post by MikeB » Mon Feb 11, 2019 10:47 pm

maxdeg wrote:
Mon Feb 11, 2019 10:03 pm
MikeB wrote:
Mon Feb 11, 2019 7:53 pm
maxdeg wrote:
Mon Feb 11, 2019 4:18 pm
MikeB wrote:
Mon Feb 11, 2019 3:02 pm
maxdeg wrote:
Mon Feb 11, 2019 10:23 am
Thanks Mike .. :D
Followed instructions to the letter.
All installed successfully.

#1 .. your compile has issues or should I say my Mac has
#2 .. ./build.sh had issues too

(build/release >> is it a folder ??)

Last login: Mon Feb 11 04:47:11 on ttys000
You have new mail.
➜ ~ ./build.sh
zsh: no such file or directory: ./build.sh

➜ ~ /Users/maxdeg/Desktop/lc0
dyld: Library not loaded: @rpath/libprotobuf-lite.dylib
Referenced from: /Users/maxdeg/Desktop/lc0
Reason: image not found
[1] 11469 abort /Users/maxdeg/Desktop/lc0

➜ ~

Any ideas please ?
(build/release >> is it a folder ??) -> yes, but you will not see it until after a successful build

zsh: no such file or directory: ./build.sh -> not sure why , but I never use zsh , you might want to try bash - type "bash -l" at the command prompt , type "zsh" again to go back again. I'm just guessing , I'm not a shell expert by any means. You might have to change build.sh permissions to run, "chmod 755 build.sh" ?

dyld: Library not loaded: @rpath/libprotobuf-lite.dylib - see my posts above ..( which I think you have seen already)
I've made a copy of your instructions - many thanks.
One problem - I cant seem to find the 'subprojects' folder anywhere - Finder/Spotlight - no help.
For sure its hiding in plain sight - point me to it please !
Okay will return to bash.
/lc0/build/release/subprojects
Thank You .. :D
For some reason that folder does not exist - search via Finder I get dumped somewhere else.
Anyway I wanted a Mac version but its not a big deal as I now have a Windoze system.

Your assistance appreciated.
You might not need anything else in folder except for the one I posted ( although I really don't know) - just add the folder and place the missing file in there. It's worth a shot. My folder has 55MB - which really surprised me, but I don't believe all of is necessary for lc0 to run.

Post Reply