237 Mn/s for Stockfish on an 2xEPYC 7742

Discussion of anything and everything relating to chess playing software and machines.

Moderators: hgm, Dann Corbit, Harvey Williamson

Forum rules
This textbox is used to restore diagrams posted with the [d] tag before the upgrade.
yorkman
Posts: 105
Joined: Thu Jul 27, 2017 8:59 pm

Re: 237 Mn/s for Stockfish on an 2xEPYC 7742

Post by yorkman » Sun Apr 12, 2020 8:15 pm

bob wrote:
Sat Apr 11, 2020 5:01 am

Where did I say that? I simply said that comparing two DIFFERENT programs (or versions of the same program) by NPS is not going to provide very interesting information. Only time NPS is really relevant is when you are doing optimizations and want to compare the changes with the original. This assumes NO other changes. Comparing ASMFish to current stockfish is again, apples to oranges. The two versions are not the same. One may have code the other does not.
Yes, the two versions are not the same now. But what I'm trying to say is that if you compare the same old version of SF with the same updates as that of asmFish I will bet you that the margin of difference in nps will still be huge on my hardware.

yorkman
Posts: 105
Joined: Thu Jul 27, 2017 8:59 pm

Re: 237 Mn/s for Stockfish on an 2xEPYC 7742

Post by yorkman » Sun Apr 12, 2020 8:22 pm

Anyone know a good tutorial on installing Wine 64bit on CentOS 8.1 for the purposes of installing Aquarium 2020 64-bit? I'd like to really compare SF between Win'10 Ent and CentOS 8.1 on my hardware. If Aquarium 2020 will look and work as well in Linux as it does in Windows and SF is at least 20% faster on it then I'd be willing to make the switch.

Years ago I tried the wine help from the rybka forum but those instructions are so outdated and are specific to Ubuntu.

In a vmware environment for testing purposes I tried the instructions here: https://tecadmin.net/install-wine-centos8/
but already I'm stuck getting error:

"configure: error: X 64-bit development files not found. Wine will be built
without X support, which probably isn't what you want. You will need
to install 64-bit development packages of Xlib at the very least.
Use the --without-x option if you really want this."

I take it I need some specific libraries but I don't know which ones or how to install them in CentOS. It has been years since I was last heavily into Linux.
All I'm able to find now is how to install wine 32bit. The link above is supposed to work for Wine 64bit too but I get that error with no clear solution. Obviously I'm going to want to test using 64bit versions of engines.

Post Reply