Page 1 of 1

Pages fail to load??

Posted: Thu Aug 29, 2019 6:56 pm
by zullil
Is it just me? Pages on this website intermittently "hang" and or time out. It varies depending on the network I'm on, ranging from barely noticeable to frequent enough to make the site unusable. The behavior is independent of which browser I use, and happens even with a freshly-installed web browser that I've never used previously. It also happens from a command line, and looks like this:

Code: Select all

$ curl -v http://talkchess.com/forum3/viewforum.php?f=2


												<div class="pagination">
							<span><i class="icon fa-clone fa-fw" aria-hidden="true"></i></span>
							<ul>
* Recv failure: Connection timed out
* Closing connection 0
curl: (56) Recv failure: Connection timed out
If it's just me, which seems hard to believe, then I'll start by contacting admins on the worst performing network.

Re: Pages fail to load??

Posted: Thu Aug 29, 2019 7:29 pm
by Eelco de Groot
I unnderstand from your post in the Help and Suggestions subforum Louis, that it was when visiting the website from your University network? No delays here but occasionally when I have not been here for a while, when you go to the main index the site wants to load some new code(?) and there is a red bar that appears shortly, it goes away too quickly to read it but I think it has something to do with HGM's code, maybe for displaying the FENs and pgns, but I'm not sure. It is just a guess but maybe that is where it stalls? Otherwise I wouldn't know.

Re: Pages fail to load??

Posted: Wed Sep 04, 2019 4:02 pm
by zullil
zullil wrote:
Thu Aug 29, 2019 6:56 pm
Is it just me? Pages on this website intermittently "hang" and or time out. It varies depending on the network I'm on, ranging from barely noticeable to frequent enough to make the site unusable. The behavior is independent of which browser I use, and happens even with a freshly-installed web browser that I've never used previously. It also happens from a command line, and looks like this:

Code: Select all

$ curl -v http://talkchess.com/forum3/viewforum.php?f=2


												<div class="pagination">
							<span><i class="icon fa-clone fa-fw" aria-hidden="true"></i></span>
							<ul>
* Recv failure: Connection timed out
* Closing connection 0
curl: (56) Recv failure: Connection timed out
If it's just me, which seems hard to believe, then I'll start by contacting admins on the worst performing network.
Resolved. Finally. Was essentially a local network hardware issue, which greatly amplified occasional slowness from this site.

Re: Pages fail to load??

Posted: Wed Sep 04, 2019 10:11 pm
by Eelco de Groot
Good to hear! But if you have more details is there maybe something the administrators could learn, why this site was slowed down in your case? I can imagine that not being https would mean some different behaviour, that might be something to look at perhaps..

Re: Pages fail to load??

Posted: Wed Sep 04, 2019 10:47 pm
by zullil
Eelco de Groot wrote:
Wed Sep 04, 2019 10:11 pm
Good to hear! But if you have more details is there maybe something the administrators could learn, why this site was slowed down in your case? I can imagine that not being https would mean some different behaviour, that might be something to look at perhaps..
All my internet traffic was being limited to 10 Mb/s on a 1000 Mb/s network. What's remarkable was that it took me so long to realize this. As far as I can tell, of the (relatively few) web sites I visit, only this site showed obvious symptoms, at least occasionally. Now that my connection is back to 1000 Mb/s, I'm no longer recognizing the issues I had previously with this site. That's all I can really say.