CEGT - rating lists March 24th 2019

Discussion of computer chess matches and engine tournaments.

Moderators: hgm, Harvey Williamson, bob

Forum rules
This textbox is used to restore diagrams posted with the [d] tag before the upgrade.
jdart
Posts: 3803
Joined: Fri Mar 10, 2006 4:23 am
Location: http://www.arasanchess.org

Re: CEGT - rating lists March 24th 2019

Post by jdart » Sat Mar 30, 2019 10:31 pm

Werner wrote:
Sat Mar 30, 2019 5:05 pm
How can I create a log file with this wb engine using winboard ?
-debugMode true should show all the commands winboard sends and receives.

--Jon

tpoppins
Posts: 919
Joined: Tue Nov 24, 2015 8:11 pm
Location: upstate

Re: CEGT - rating lists March 24th 2019

Post by tpoppins » Tue Apr 02, 2019 5:44 pm

Werner wrote:
Sat Mar 30, 2019 9:05 am
in a short testmatch with 100 games I have had around 50 games lost due to an illegale move:

Odd. I counted over 700 games I played with v2.0.34, including 400+ 4CPU ones, and only found one game that had to be replayed. It was from the 4CPU test, but I cannot determine now what was the error or if the error was on Schooner's part.

It's installed as an xboard engine under Cute Chess, using 512 MB hash as well.

I recall seeing precisely this error with another engine. The situation was different but I suspect that underlying cause is the same -- undefined behavior possibly caused by a bug in the hashtable code.
Tirsa Poppins
CCRL

D Sceviour
Posts: 441
Joined: Mon Jul 20, 2015 3:06 pm
Contact:

Re: CEGT - rating lists March 24th 2019

Post by D Sceviour » Tue Apr 02, 2019 7:38 pm

tpoppins wrote:
Tue Apr 02, 2019 5:44 pm
The situation was different but I suspect that underlying cause is the same -- undefined behavior possibly caused by a bug in the hashtable code.
Another possibility may be incompatible mmx or sse hardware. Try using Schooner's non-popcount generic version.

User avatar
Werner
Posts: 2392
Joined: Wed Mar 08, 2006 9:09 pm

Re: CEGT - rating lists March 24th 2019

Post by Werner » Wed Apr 03, 2019 9:52 am

Thank you for the answers. Under Arena I played 1000 games now without any problems.

I tried out Winboard again with log on - and could not repeat this behaviour. I used the same pc.
Werner

Post Reply