On-line engine blitz tourney January

Discussion of chess software programming and technical issues.

Moderators: bob, hgm, Harvey Williamson

Forum rules
This textbox is used to restore diagrams posted with the [d] tag before the upgrade.
User avatar
hgm
Posts: 23772
Joined: Fri Mar 10, 2006 9:06 am
Location: Amsterdam
Full name: H G Muller
Contact:

On-line engine blitz tourney January

Post by hgm » Thu Jan 22, 2015 10:45 am

The monthly on-line engine blitz tourney for January will take place on:

Saturday January 24, 3pm Boston time (21:00 Amsterdam time)

To connect:

winboard -zp -ics -icshost winboard.nl -icshelper timeseal -fcp ENGINE.exe -fd ENGINEFOLDER -autoKibitz

(for UCI engines, add -fUCI)

Joost Buijs
Posts: 987
Joined: Thu Jul 16, 2009 8:47 am
Location: Almere, The Netherlands

Re: On-line engine blitz tourney January

Post by Joost Buijs » Thu Jan 22, 2015 4:33 pm

Although I have many other things to do this is something I don't want to miss.

See you on Saturday!

op12no2
Posts: 349
Joined: Tue Feb 04, 2014 11:25 am
Location: Mumbles, Wales, UK.
Full name: Colin Jenkins
Contact:

Re: On-line engine blitz tourney January

Post by op12no2 » Thu Jan 22, 2015 5:57 pm

Is there a way I can test my user name and password, using your command line I'm getting "connection closed by ICS".

User avatar
hgm
Posts: 23772
Joined: Fri Mar 10, 2006 9:06 am
Location: Amsterdam
Full name: H G Muller
Contact:

Re: On-line engine blitz tourney January

Post by hgm » Thu Jan 22, 2015 8:39 pm

Seems they rebooted the host VPS again. I just restarted the ICS, so it should work now. "Connection closed by ICS" is just WinBoard's standard message if for some reason the TCP/IP connection does not work.

op12no2
Posts: 349
Joined: Tue Feb 04, 2014 11:25 am
Location: Mumbles, Wales, UK.
Full name: Colin Jenkins
Contact:

Re: On-line engine blitz tourney January

Post by op12no2 » Thu Jan 22, 2015 9:09 pm

All good now, thanks HG.

brtzsnr
Posts: 433
Joined: Fri Jan 16, 2015 3:02 pm
Contact:

Re: On-line engine blitz tourney January

Post by brtzsnr » Thu Jan 22, 2015 10:23 pm

I also have the same issue using xboard: I get "Connection closed by ICS".

Do I need an account or does connecting suffice?

jorose
Posts: 269
Joined: Thu Jan 22, 2015 2:21 pm
Location: Zurich, Switzerland
Full name: Jonathan Rosenthal

Re: On-line engine blitz tourney January

Post by jorose » Fri Jan 23, 2015 5:02 pm

Just wanted to say that I seem to have the same problem as Alexandru on Linux and using xboard. Do I have to do anything aside from the given command from terminal?

Also I wanted to say thank you for hosting this! I'm Looking forward to my engine's first ever competition :D It's gonna be a lot of fun, especially as I haven't implemented any king safety features yet :P

brtzsnr
Posts: 433
Joined: Fri Jan 16, 2015 3:02 pm
Contact:

Re: On-line engine blitz tourney January

Post by brtzsnr » Fri Jan 23, 2015 5:25 pm

I managed to connect eventually. The problem was not the host, but the timeseal. The -icshelper timeseal is actually running timeseal command which is not present under Linux. You can however use openseal.

http://www.bergo.eng.br/chess/openseal.c

jorose
Posts: 269
Joined: Thu Jan 22, 2015 2:21 pm
Location: Zurich, Switzerland
Full name: Jonathan Rosenthal

Re: On-line engine blitz tourney January

Post by jorose » Fri Jan 23, 2015 6:16 pm

Thanks a ton! Seems to be working now!

Cheers,
Jonathan

jorose
Posts: 269
Joined: Thu Jan 22, 2015 2:21 pm
Location: Zurich, Switzerland
Full name: Jonathan Rosenthal

Re: On-line engine blitz tourney January

Post by jorose » Sat Jan 24, 2015 11:49 am

As of currently I am able to log on to the server as a guest (yay!) including with my engine, as well as start a game against StockfishRB without issues. However, after my engine has successfully made its first move and SF replies, xboard instantly crashes with a segfault, presumably due to my engine. This does not occur when I am simply using xboard to play against my engine locally.

I was wondering if anybody has any ideas what the problem could be or what messages my engine might be getting that it wouldn't if it were to just play locally?

I'm aware this forum isn't here to solve my problems, but I'm desperate :P.

Post Reply