Simplifying code

Discussion of chess software programming and technical issues.

Moderators: bob, hgm, Harvey Williamson

Forum rules
This textbox is used to restore diagrams posted with the [d] tag before the upgrade.
Henk
Posts: 6386
Joined: Mon May 27, 2013 8:31 am

Re: Simplifying code

Post by Henk » Fri Jun 19, 2020 12:03 pm

Sven wrote:
Fri Jun 12, 2020 1:03 pm
mhouppin wrote:
Fri Jun 12, 2020 12:17 pm
Henk wrote:
Fri Jun 12, 2020 12:01 pm
Now I have this for alpha beta search. Don't like it. Too many if statements.

Code: Select all

  
 ISearchResult SearchMoves(IChessPosition position, IMovePrioQ prioQ, IVariation initialVariation, int depth, 
                                     int plyCount, int lb, int ub)
        {
            if (!(TimeManagement.SearchExpired(Level))
                && (initialVariation == null || initialVariation.Value < ub)
                && prioQ.Count() > 0)
            {
                var mv = prioQ.Top();
                var firstVariation = SearchMove(position, mv, initialVariation, depth, plyCount, lb, ub);
                if (firstVariation == null)
                {
                    return null;
                }
                else
                {
                    var nextLb = Max(lb, firstVariation.Value);
                    var remPrioQ = prioQ.Pop();
                    var remResult = SearchMoves(position, remPrioQ, firstVariation, depth, plyCount, nextLb, ub);
                    if (firstVariation != initialVariation)
                    {
                        return ResultBuilder.BuildResult(firstVariation, remResult);
                    }
                    else
                    {
                        return remResult;
                    }
                }
            }
            return null;
        }
What about reordering it like that:

Code: Select all

ISearchResult SearchMoves(IChessPosition position, IMovePrioQ prioQ, IVariation initialVariation, int depth, int plyCount, int lb, int ub)
{
    if (TimeManagement.SearchExpired(Level)
        || (initialVariation && initialVariation.Value >= ub)
        || prioQ.Count() <= 0)
    {
        return null;
    }
    
    var mv = prioQ.Top();
    var firstVariation = SearchMove(position, mv, initialVariation, depth, plyCount, lb, ub);
    if (firstVariation == null)
    {
        return null;
    }
    var nextLb = Max(lb, firstVariation.Value);
    var remPrioQ = prioQ.Pop();
    var remResult = SearchMoves(position, remPrioQ, firstVariation, depth, plyCount, nextLb, ub);
    if (firstVariation != initialVariation)
    {
        return ResultBuilder.BuildResult(firstVariation, remResult);
    }
    return remResult;
}    
Less indentations and if-else blocks by exploiting the "return" statements.
I would have proposed almost the same, for the same reasons. It would improve readability. However, it would not reduce the number of if's. Addressing that would require to know a bit more background.

@Henk: What does "return null" mean in this context? Encountered an illegal move? A leaf node (e.g. mate/stalemate/other draw)? How and where do you differentiate between these?

There is another issue, even a major one I believe: SearchMoves() will be called recursively N times to process a move list ("move priority queue") of length N, unless there is some cutoff inbetween. That means: searching to depth D with an average move list size of N implies that D*N recursive calls are made. This will create really a huge overhead at runtime caused by a very huge runtime stack and a lot of temporary objects being created and destroyed on the fly, which I consider to be a bad design. E.g. for processing one node at one level in the search tree there will be up to N internal move priority queue objects of length N, N-1, N-2, ..., 1, caused by "var remPrioQ = prioQ.Pop();" in combination with the mentioned tail recursion strategy. I would recommend a classical loop instead ...

Finally I do not understand the alpha-beta algorithm in that implementation yet. Where is the code for the AB cutoff? The condition "initialVariation.Value >= ub" does not look like it to me since it causes a "return null" instead of returning a SearchResult carrying either "initialVariation.Value" or "ub" as its value.
Ok here is the loop version. There even was a bug in it for I forgot to ignore curResult if time is up.
(Code below assumes iterative deepening move goes first)
Don't know if recursive version is good enough if you implement prioq as a balanced tree.
Then remPrioQ = prioQ.Pop() is O(log n) .

Code: Select all

     ISearchResult SearchMoves(IChessPosition position, IPositionHistory positionHistory, 
                                  IMovePrioQ prioQ, ISearchResult resultSofar, int depth, 
                                  int plyCount, int lb, int ub)
        {
            var curResult = resultSofar;
            foreach (var mv in prioQ)
            {
                if (TimeManagement.SearchExpired(Level))
                {
                    if (depth == Level)
                    {
                        return curResult;
                    }
                    else
                    {
                        return resultSofar;
                    }
                }
                else if ( curResult.PV != null && curResult.PV.Value >= ub )
                {
                    return curResult;
                }
                else {
                    curResult = SearchMove(position, positionHistory, mv, curResult, depth, plyCount, lb, ub);
                    if (curResult.PV != null)
                    {
                        lb = Max(lb, curResult.PV.Value);
                    }
                }
            }
            return curResult;
        }

Henk
Posts: 6386
Joined: Mon May 27, 2013 8:31 am

Re: Simplifying code

Post by Henk » Fri Jun 26, 2020 10:56 am

Made position immutable so now I get this:

Code: Select all

 var nextPos = position.Move(mv);
 var key = KeyFactory.BuildKey(position.Board);
 var nextPositionHistory = positionHistory.Add(key);
 var nextPsqValue = psqValue + position.CurPlayer * mv.PieceSquareDelta(position, PSQTableEval.PieceSquareTable);
Actually position history and piece square value should be part of position. But sometimes you don't need them.
So copying and updating them would not be necessary when making a move in some cases.

Also made transposition table immutable. Code is running slow by the way.

So code doesn't get simpler.

What will be next step. Creating a monad for counting nodes or handling search result when time is up?

bob
Posts: 20914
Joined: Mon Feb 27, 2006 6:30 pm
Location: Birmingham, AL

Re: Simplifying code

Post by bob » Mon Jun 29, 2020 3:51 am

Henk wrote:
Fri Jun 12, 2020 1:00 pm
Sven wrote:
Fri Jun 12, 2020 12:48 pm
Henk wrote:
Fri Jun 12, 2020 12:33 pm
Yes looks better. But I saw a video about monads recently. Although i am not sure I understand it.
Don't know anything about category theory.

So maybe I could use something like a monad to hide some obvious recurring tests.

Monad is a functor plus a flatten operation I understood.
Already unfamiliar with functors.
Good to hear that you think a lot about theory ... But what is your goal? To have a working chess engine that plays decent chess and has source code without bugs that can be maintained and changed quite easily (which is somehow related to "being simple" and "you like it"!)? Or to have an engine that matches common formal theories?
I hate bugs and code i can't understand or change easily.
Today and previous week I had to undo my changes after repairing 1000 compile time errors. Much misery.
Almost impossible to replace bitboards by something else in my source code.

So code should be written such that it is easy to make changes. That is most important.
my comment to the above is the multiple returns make code harder to read. The cleanest function has one entry and one exit. (hard to have more than one entry but in ASM or old FORTRAN it was easy to do). It sometimes helps (multiple returns) but often it makes the code harder to read unless you have long blocks of code, each with its own return. No point making it hard to read, which makes it hard to modify.

Post Reply