On-line engine blitz tourney November

Discussion of chess software programming and technical issues.

Moderators: bob, hgm, Harvey Williamson

Forum rules
This textbox is used to restore diagrams posted with the [d] tag before the upgrade.
Joost Buijs
Posts: 987
Joined: Thu Jul 16, 2009 8:47 am
Location: Almere, The Netherlands

On-line engine blitz tourney November

Post by Joost Buijs » Wed Nov 06, 2019 12:39 pm

The monthly on-line engine blitz tourney for November will take place on:

Saturday November 9, 2pm Boston time (20:00 Amsterdam time)

To connect:

winboard -zp -ics -icshost nightmare-chess.nl -icshelper timeseal -fcp ENGINE.exe -fd ENGINEFOLDER -autoKibitz

(for UCI engines, add -fUCI)

People without an account on the (new) server can submit a request for a new account to admin@nightmare-chess.nl

Tourney format: 9 rounds Swiss 5/1

Our TD will be: Eendje (Lisebeth) from ICC

Henk
Posts: 5827
Joined: Mon May 27, 2013 8:31 am

Re: On-line engine blitz tourney November

Post by Henk » Wed Nov 06, 2019 3:38 pm

Previous tourney I had to reconnect after each game otherwise my engine would not move.
Has that issue already been fixed. Or what do I have to change in my engine to fix that problem?

Might also be I did not use the right conection string. I used this one:

winboard -zp -ics -icshost nightmare-chess.nl -icshelper timeseal -fcp "dotnet C:\Users\Gebruiker\source\repos\ChessLibraryCore\SkipperConsoleApp2\bin\Release\netcoreapp2.2\SkipperConsoleApp2.dll" -autoKibitz

Joost Buijs
Posts: 987
Joined: Thu Jul 16, 2009 8:47 am
Location: Almere, The Netherlands

Re: On-line engine blitz tourney November

Post by Joost Buijs » Wed Nov 06, 2019 6:03 pm

Henk wrote:
Wed Nov 06, 2019 3:38 pm
Previous tourney I had to reconnect after each game otherwise my engine would not move.
Has that issue already been fixed. Or what do I have to change in my engine to fix that problem?

Might also be I did not use the right conection string. I used this one:

winboard -zp -ics -icshost nightmare-chess.nl -icshelper timeseal -fcp "dotnet C:\Users\Gebruiker\source\repos\ChessLibraryCore\SkipperConsoleApp2\bin\Release\netcoreapp2.2\SkipperConsoleApp2.dll" -autoKibitz
You were the only one with this issue, so it is not a server problem. Why does your build system creates a DLL instead of an executable? Do you use 'Console Application (.Net Core)'? maybe you can use 'Console Application (.Net Framework)' to create a normal executable. You can also try to specify the engine executable with -fcp and the engine directory with -fd.

Honestly, I don't know what happens when you execute a DLL with dotnet, I have no experience with that.

Henk
Posts: 5827
Joined: Mon May 27, 2013 8:31 am

Re: On-line engine blitz tourney November

Post by Henk » Wed Nov 06, 2019 7:05 pm

I used same dotnet construction on hgm's server giving no problems. So something is different.

Joost Buijs
Posts: 987
Joined: Thu Jul 16, 2009 8:47 am
Location: Almere, The Netherlands

Re: On-line engine blitz tourney November

Post by Joost Buijs » Wed Nov 06, 2019 7:48 pm

Henk wrote:
Wed Nov 06, 2019 7:05 pm
I used same dotnet construction on hgm's server giving no problems. So something is different.
Maybe something has changed on your end.

I know that you had a bad computer crash several months ago, and that you had to setup everything new on another PC, after this event you didn't play on HGM's server anymore.

The server is online 24 hours a day, usually there are several programs logged in and ready to play, so it should not be too difficult to find out why your program does not respond anymore after playing a single game.

Daniel Anulliero
Posts: 688
Joined: Fri Jan 04, 2013 3:55 pm
Location: Nice

Re: On-line engine blitz tourney November

Post by Daniel Anulliero » Thu Nov 07, 2019 5:25 pm

Hi Joost
Can you send me an account for Isa ?
All the best
Dany

Joost Buijs
Posts: 987
Joined: Thu Jul 16, 2009 8:47 am
Location: Almere, The Netherlands

Re: On-line engine blitz tourney November

Post by Joost Buijs » Thu Nov 07, 2019 7:57 pm

Daniel Anulliero wrote:
Thu Nov 07, 2019 5:25 pm
Hi Joost
Can you send me an account for Isa ?
All the best
Dany
Hi Daniel,

Done..., I've sent you a PM with the password.

Regards,

Joost

Henk
Posts: 5827
Joined: Mon May 27, 2013 8:31 am

Re: On-line engine blitz tourney November

Post by Henk » Fri Nov 08, 2019 12:16 pm

Joost Buijs wrote:
Wed Nov 06, 2019 7:48 pm
Henk wrote:
Wed Nov 06, 2019 7:05 pm
I used same dotnet construction on hgm's server giving no problems. So something is different.
Maybe something has changed on your end.

I know that you had a bad computer crash several months ago, and that you had to setup everything new on another PC, after this event you didn't play on HGM's server anymore.

The server is online 24 hours a day, usually there are several programs logged in and ready to play, so it should not be too difficult to find out why your program does not respond anymore after playing a single game.
When I try "match …" It complains "tournament variable is not set"

Joost Buijs
Posts: 987
Joined: Thu Jul 16, 2009 8:47 am
Location: Almere, The Netherlands

Re: On-line engine blitz tourney November

Post by Joost Buijs » Fri Nov 08, 2019 12:38 pm

Henk wrote:
Fri Nov 08, 2019 12:16 pm
Joost Buijs wrote:
Wed Nov 06, 2019 7:48 pm
Henk wrote:
Wed Nov 06, 2019 7:05 pm
I used same dotnet construction on hgm's server giving no problems. So something is different.
Maybe something has changed on your end.

I know that you had a bad computer crash several months ago, and that you had to setup everything new on another PC, after this event you didn't play on HGM's server anymore.

The server is online 24 hours a day, usually there are several programs logged in and ready to play, so it should not be too difficult to find out why your program does not respond anymore after playing a single game.
When I try "match …" It complains "tournament variable is not set"
I see that your tournament variable is still set (maybe because you left the server before the tourney was finished), now you can't match players without their tourney variable set.

Just login and type: set tourney 0

This should solve it.

With the command: var - you can see the state of all your variables.

Henk
Posts: 5827
Joined: Mon May 27, 2013 8:31 am

Re: On-line engine blitz tourney November

Post by Henk » Fri Nov 08, 2019 6:21 pm

Joost Buijs wrote:
Fri Nov 08, 2019 12:38 pm
Henk wrote:
Fri Nov 08, 2019 12:16 pm
Joost Buijs wrote:
Wed Nov 06, 2019 7:48 pm
Henk wrote:
Wed Nov 06, 2019 7:05 pm
I used same dotnet construction on hgm's server giving no problems. So something is different.
Maybe something has changed on your end.

I know that you had a bad computer crash several months ago, and that you had to setup everything new on another PC, after this event you didn't play on HGM's server anymore.

The server is online 24 hours a day, usually there are several programs logged in and ready to play, so it should not be too difficult to find out why your program does not respond anymore after playing a single game.
When I try "match …" It complains "tournament variable is not set"
I see that your tournament variable is still set (maybe because you left the server before the tourney was finished), now you can't match players without their tourney variable set.

Just login and type: set tourney 0

This should solve it.

With the command: var - you can see the state of all your variables.
Problem was a missing ''go" command. New server does not use it after first move from opponent. I already did a quick and dirty repair. So looks like it is fixed now in my engine.

I used to use 'go"command to change sides during a game when I was playing against my engine for testing purposes. But that won't work anymore. For current implementation can now handle only one "go" command per game.

If I play against fairy-max with winboard running locally on my computer it still has to work with a go command.

Post Reply