WinBoard 4.3.15 released

Discussion of anything and everything relating to chess playing software and machines.

Moderators: hgm, Dann Corbit, Harvey Williamson

Forum rules
This textbox is used to restore diagrams posted with the [d] tag before the upgrade.
User avatar
hgm
Posts: 26437
Joined: Fri Mar 10, 2006 9:06 am
Location: Amsterdam
Full name: H G Muller
Contact:

WinBoard 4.3.15 released

Post by hgm » Fri Jan 02, 2009 6:29 pm

The new WinBoard 4.3.15 can now be downloaded from the WinBoard forum.
Most important change is that WinBoard now supports a GUI book in Polyglot format,
which both WB and UCI engines can use. WinBoard 4.3.15 support extensions to the WB
protocol that allow the user to interactively set standard options on UCI engines
(through a new version of Polyglot that also supports these commands), as well as
on native WB engines that support this feature (the memory, cores and egtpath
commands).

Image

Also new is that the WinBoard executable is now bundled with the matching Polyglot
executable, as well as the PSWBTM tournament manager. The bundle also contains two
pre-installed sample engines (one WB, one UCI), an opening book, Nunn and Silver
start positions and board texture bitmaps, all ready to run.

As this release is mainly an xboard release, there aren't too many other new
features, although there are some:

New command-line options:
* /rewindIndex=N for replaying a game or position file after a given number of games
* /sameColorGames=N for holding matches where the same player has white on all games
* /egtFormats="..." informs the engines where to find tablebases and bitbases

New menus:
+ nr of CPUs for SMP engines can be set in the UCI options dialog
+ Time-odds factors can be set in time-control dialog
+ Own book options can be set in UCI options dialog
+ Absolute engine scores can be indicated in the engine options dialog
+ Superchess added to variant menu

General enhancements
# WB engines can use the GUI book
# auto-increment mode for the game and position index in match mode, so that all games
of a match can start from different positions
# supports WB-protocol extensions memory, cores and egtpath. (See updated WB protocol specs.)


Image

Stan Arts

Re: WinBoard 4.3.15 released

Post by Stan Arts » Fri Jan 02, 2009 6:50 pm

Great work H.G. !

krazyken

Re: WinBoard 4.3.15 released

Post by krazyken » Fri Jan 02, 2009 7:02 pm

Thanks! compiles and runs OK under Mac OS X.

The man page isn't updated with the new command line options. Is there a summary somewhere of the new commands?

Edit: I see some in the README, but they don't actually say what they do...

User avatar
hgm
Posts: 26437
Joined: Fri Mar 10, 2006 9:06 am
Location: Amsterdam
Full name: H G Muller
Contact:

Re: WinBoard 4.3.15 released

Post by hgm » Fri Jan 02, 2009 7:07 pm

If you use the Makefile, it should also have created an xboard.man file in the xboard directory. This should be an updated man page. To get the man command use it on my Ubuntu I had to rename it to xboard.6, gzip it, and move it to /usr/share/man/man6/xboard.6.gz

There are also a few html files in the xboard directory; in particular manual.html and xboard.html should list differences with 4.2.7.

krazyken

Re: WinBoard 4.3.15 released

Post by krazyken » Fri Jan 02, 2009 7:32 pm

ahh I found it now, The "make install" put the page in a directory farther down the MANPATH than what the old one was in. My Bad.

Michel
Posts: 2236
Joined: Sun Sep 28, 2008 11:50 pm

Re: WinBoard 4.3.15 released

Post by Michel » Fri Jan 02, 2009 7:55 pm

To get the man command use it on my Ubuntu I had to rename it to xboard.6, gzip it, and move it to /usr/share/man/man6/xboard.6.gz
Installing the man page should normally have been handled by autoconf/automake....

I think these are supported on MACOSX as well.

krazyken

Re: WinBoard 4.3.15 released

Post by krazyken » Fri Jan 02, 2009 8:02 pm

Michel wrote:
I think these are supported on MACOSX as well.
That they are. It's just that I ended up with multiple manpages installed. With the old one coming first in MANPATH.

krazyken

Re: WinBoard 4.3.15 released

Post by krazyken » Thu Jan 08, 2009 12:56 am

it's been working great for me!

2 issues I've noticed:
Mode --> Show Evaluation Graph seems to do nothing.
The show Engine output window is nice but there is a small bug in calculating NPS:
Image

User avatar
hgm
Posts: 26437
Joined: Fri Mar 10, 2006 9:06 am
Location: Amsterdam
Full name: H G Muller
Contact:

Re: WinBoard 4.3.15 released

Post by hgm » Thu Jan 08, 2009 8:03 am

OK, thanks for the bug report. Strange that the .3k suffix appears; I will have a look into the code that calculates the NPS and prepares the string for showing it in the widget.

Did other people notice this problem?

The eval graph is indeed not implemented yet. I learned how to do popups now with the Athena widgets set XBoard is written with, but I still have to learn how to do graphics output in such a window. But when I was re-organizing the menus, I already added it as a dummy.

So this will have to wait for a future release. Once I know how to do the graphics, I could also add a popup window for displaying engine logo's, for people that like this kind of things.

User avatar
hgm
Posts: 26437
Joined: Fri Mar 10, 2006 9:06 am
Location: Amsterdam
Full name: H G Muller
Contact:

Re: WinBoard 4.3.15 released

Post by hgm » Thu Jan 08, 2009 11:32 am

I don't think there is an XBoard bug here: Gibbon reports 44M nodes in 0.11 sec. that is ~400,000,000 NPS or ~400,000k. Printing the extra decimal place seems a bit unnecessary, though.

Of course it seems unlikely that Gibbon is telling the truth here. But to know if XBoard is to blame for that I would have to see what Gibbon was actually sending it.

Post Reply